Getting Started

    This chapter gives you a brief overview of the chemical drawing features of MarvinSketch.

    Drawing

    To place an atom on the canvas, either select one from the Atoms Toolbar or type its chemical symbol and place it on the canvas with a left-click.

    To draw a single bond, click the Single Bond button on the Tools Toolbar and place the single bond on the canvas. It is possible to select different bond types other than the default single bond. To select a different type, simply open the drop-down list by clicking the ▼ button.

    The bonds of MarvinSketch

    {info} You can also change existing bonds on the canvas through this menu, the context menu (Type), or by using keyboard shortcuts. For more information regarding shortcuts, see Shortcuts in MarvinSketch.

    To draw a chain, click on the Draw Chain button on the Tools Toolbar and drag on the canvas. To place a template on the canvas, select a template from the Advanced Templates Toolbar and click on the canvas. The template can be rotated by holding the left mouse button and dragging. To increase or decrease a charge, click the + or - buttons on the tools toolbar and click the desired atom. Alternatively, you can set the charge of an atom by hovering the cursor over it and hitting the + or - keys.

    Selecting in MarvinSketch

    There are different selection tools in MarvinSketch. These are as follows:

    • Rectangle Selection: The default selection tool. Hold the left mouse button while selecting and release the button when you are ready.
    • Lasso Selection: Hold the left mouse button and move the cursor around the fragment. Release the button when you are ready with the selection.
    • Structure Selection: Single-click any atom of a structure to select the whole structure.

    The Lasso Selection and the Structure Selection can be chosen through a drop-down list.

    The selection modes of MarvinSketch

    To select an atom, bond, or group, use the Rectangle Selection or the Lasso Selection mode (single-click, drawing selection area). To select a structure, use Rectangle Selection or Lasso Selection mode (double-click any of its atom or bond), or Structure Selection (single-click). To add more parts to a selection or remove parts of a selection, hold the Shift key while clicking on the desired parts. To invert the selection, for example, to select everything previously unselected, use Edit > Invert selection (Ctrl+Shift+I). If nothing is selected on the canvas, this action selects everything on it. To deselect, click on an empty place of the canvas.

    Deleting in MarvinSketch

    To delete an atom or a bond, select the Erase tool from the General Toolbar, then click an atom or bond you wish to delete. It is also possible to select the deletion area by dragging. Also, the delete function can be used through Edit > Delete or the context menu. You can also delete a previously selected area by clicking the Erase button or pressing the Delete key.

    Move Rotate Zoom Scale

    To move an atom, drag it with the mouse in any of the selection modes. To move a selection, press Space once or move the cursor toward the center until a blue rectangle appears, drag while holding the left mouse button.

    To rotate a selection in 2D, press Space twice or move the cursor over the selection until a blue rotation symbol appears, drag while holding the left mouse button. To rotate a selection in 3D, press Space three times or navigate to Edit > Transform > Rotate in 3D and choose from the options, drag while holding the left mouse button.

    There are several ways to zoom in and zoom out. These are the following:

    • Holding Ctrl and using the mouse wheel.
    • Using the zoom buttons which are available on the General Toolbar ( Zoom In / Zoom Out ).
    • Specifying the zoom percentage either by using the drop-down list or by navigating to View > Zoom Level. Setting the value to Allzooms in or zooms out objects to the full size of the canvas.
      Specifying the zoom percentage of MarvinSketch
    • Pressing F6 and dragging vertically to zoom.

    Tricks and Tips

    • Operations can be reverted by using the Undo and Redo buttons on the General Toolbar.
    • Paste names or InChi directly onto the canvas, they will be converted into chemical structures right away.
    • An easy way to modify existing properties or add new properties to an atom, bond, or selection is through context menu items (right-click to access it).
    • It is possible to introduce any kind of element and a lot of query features through the Advanced Tab of the Periodic Table dialog.
    • You can use the build-in structure templates by navigating to Insert > Template Library.
    • You can also import peptide, DNA, and RNA sequences by navigating to Edit > Source.
    • You can easily copy the IUPAC name by navigating to Structure > Structure to name. It is also possible to add IUPAC numbering (View > Advanced > Atom numbering > IUPAC numbering).
    • Calculate chemical properties, for example, pKA, logD, or Solubility by using the options of the Calculations menu(additional license needed).
    • To check whether your molecule is chemically correct, click the Check Structure button, which is available from the General toolbar.
    • To clean a molecule in 2D or 3D, use the respective buttons. These actions are also available through shortcuts Ctrl+2/Ctrl+3).
    • It is possible to check your molecule in online databases (Chemicalize, Reaxys®, Pubchem) by navigating to File > Find Structure Online.