User Settings

    User settings such as adjusting memory settings, and changing structure display for hit alignment and highlighting can generally be made by accessing the Options window (Tools -> Options from the main menu, or InstantJChem -> Preferences... on Mac).

    General settings

    1. Web browser selection and settings for proxy server selection.

    Start page

    1. Setting the page that IJC will display when it starts. The possibilities include:

     1.
        Dashboard
    
     1.
        Simple Federated Search page
    
     1.
        Any specified view (form view or grid view)
    
     1.
        None (IJC will open with the same windows open as when it last closed) There is also a setting that determines whether the window will open maximised (e.g. take up all the space within the main IJC window).
        <a name="src-1804988-usersettings-keymapkeymapsettings"></a>

    Keymap settings

    Keyboard bindings. You probably do not need to change these.

    Miscellaneous settings

    Various settings that affect IJC:

    Clipboard settings

    These settings control how much data can be copied to the clipboard to prevent memory being exhausted when using large data sets

    Confirmations

    This section lets you set options for some confirmation dialogs that IJC uses. You can choose not to see these confirmations if you wish.

    Lists and Queries

    These settings control what happens to lists and queries.

    • Number of temporary queries and lists to remember

    • Maximum temporary list size that is created when a query is executed (to prevent memory exhaustion).

    • Whether to truncate over-size lists or not to save them.

    • Whether to create temporary queries when there are no hits or the whole data set is returned.

    • Whether to clear the current query when 'Show All' is executed

    Molecule view/edit

    Structure search - hit alignment and highlighting

    When performing queries on structures, it is possible to specify how the found substructure is displayed by setting 'hit highlighting' and 'hit alignment'. Hit highlighting can be used to display the part of the structure that matches the query structure in a different colour. Hit alignment refers to rotating the hit structure so that it is displayed in the same orientation as the query structure. Typically both are used together, but each can be used on their own, or neither can be used. These only apply to substructure searching.

    To change structure display:

    1. Choose Tools -> Options from the main menu. The Options window appears.

    1. Expand the Structure Display node.

    1. In the Hit highlighting and alignment default drop-down list, specify whether highlighting and alignment are to be active.

    1. In the Hit color drop-down list box, select a color to identify hit structures.

    1. In the Non-hit color drop-down list box, select a color to identify structures that do not match the query structure in a performed query.

    1. Click OK. Molecule editor

    In IJC 5.4 we introduced the possibility to use different structure editors. Currently ChemDraw is supported (only on Windows). Changing this setting lets you use ChemDraw instead of Marvin Sketch for some operations such as editing structures or drawing queries.

    Do note that only Marvin Sketch will be fully supported in IJC. We cannot guarantee functionality of third party sketchers, and in some cases (e.g. Markush structures and using the full structure search capabilities of JChem) only Marvin Sketch can be used.

    Other settings

    Memory settings can be adjusted to determine how much memory Java is allowed to use in IJC. If you are working with very large databases of structures, additional memory may be required. See Memory Usage and Settings for additional information.

    To change memory settings:

    1. Choose Tools -> Options... from the main menu (or InstantJChem -> Preferences... on Mac). The Options window appears.

    1. Choose the Miscellaneous section and select the 'Other settings' tab.

    1. Under 'Memory settings' set the memory values (in megabytes) for the application's starting and maximum sizes.

    1. Click OK.

    1. Restart Instant JChem

    1. Please note: In order to edit memory settings on later versions of windows (7) the IJC application will require to be executed as administrator.

    1. In order to complete, simply r-click on the IJC desktop icon and select 'run as administrator'.

    As an approximate guide work on the basis that IJC needs 64MB for its own use and each million structures that you have will take up approximately another 100MB. For searching in Markush structures more will be needed.
    images/download/attachments/1804988/RunAsAdminToEditIJCMemory.png

    The SQL logging setting tells IJC to log all SQL statements that are executed. These are written to the IJC log file (viewable using View -> Instant JChem Log File). This is not advised for normal use, but can be useful when investigating problems and performance issues.

    Form and Gridview settings allow the autosaving of views when design changes are made to be turned off. When turned off the view must be manually saved when you are finished with your changes.

    Shared projects

    Currently configured shared projects are listed, and you can add or remove shared projects. See the shared projects documentation for more details

    Options:

    Option Description
    Open only the last opened project on restart This option causes IJC to only open the last project you had opened when it restarts. Any other project will not be opened
    Disable restoring closed projects on restart This option causes IJC not to re-open shared projects that have been manually closed by the user

    {primary} Only one of the above options should be set, not both.

    Chemical Terms settings

    Chemical terms favourites. New favourites can be added and current ones removed or edited.