Structure Display Options in MarvinView

There is a wide range of functions related to the display of the molecules. These settings can be found in the View menu and in the Preferences dialog. Additionally, you can move, rotate and zoom in/out the structure.

Molecule Format

You can set the display format for the molecule and screen resolution using the View > Display submenu. Available molecule formats are Wireframe, Wireframe with Knobs, Sticks, Ball and Stick, and Spacefill.

Colors

The View > Colors submenu allows you to specify the color scheme of the molecules. The available options are:

  • Monochrome

  • CPK

  • Shapely - based on RasMol's shapely color scheme for nucleic and amino acids

  • Group - based on PDB residue numbers

  • Atom Set - based on previously defined atom set coloring (can be set in MarvinSketch)

Implicit/Explicit Hydrogens

Marvin has a number of options for the display of implicit and explicit hydrogens. Because Marvin is chemically intelligent, it will automatically add hydrogens as necessary within the structure. They are called implicit hydrogen atoms, are always displayed without bonds and based on the options set in the View menu. In case of Ball & Stick and Spacefill modes, the impilcit hydrogen atoms are never displayed.

To view all hydrogen atoms explicitly, displayed as atoms with bonds connected to neighbors, chose Structure > Add > Explicit H Atoms. The Structure > Remove > Explicit H atoms will remove every explicitly drawn hydrogen from your structure.

Marking Atoms

Hover the cursor over an atom and it will be marked by light blue circle. Clicking on it will select the atom in question and the circle will turn dark blue. At the same time, you can mark one atom, and select another one even if they are in different molecules. A property change event is sent on every atom mark. See developer guide for details.

images/download/attachments/1803492/hover_over.png

Error Highlighting

Marvin can not automatically correct all valence errors or any reaction errors. Instead, these errors are highlighted and you may make the appropriate corrections yourself. This option can be enabled and disabled using the the Edit > Preferences dialog window.

Saving Display Options

Many of the display settings in Marvin are saved and reloaded the next time you start the program. Background color, molecule color scheme, and hydrogen visibility can be set from the View menu and will be saved automatically when you exit the program. Other options, including look & feel, error highlighting, and object visibility can be set using the Preferences dialog window from the Edit menu.