Moving and Rotating

It is possible to move and rotate the selected structures.

Move the Selected Structure

  1. Select the structure

  2. Move the cursor toward the center of the selected structure until a blue rectangle appears. You can use the Space key to alternate between transformation modes.

  3. Drag the structure with the mouse.

images/download/attachments/1805988/Structure_Move.png

Rotate the Selected Structure in 2D

  1. Select the structure

  2. Move the cursor toward the center of the selected structure until a blue cogwheel appears. You can use the Space key to alternate between transformation modes.

  3. Rotate the structure by moving the mouse while holding the left mouse button.

images/download/attachments/1805988/Structure_Rotate2D.png

Rotate the Selected Structure in 3D

  1. Select the structure

  2. Hit the Space key three times, a blue wheel appears.

  3. Rotate the structure by moving the mouse while holding the left mouse button.

images/download/attachments/1805988/Structure_Rotate3D.png

3D Rotation Options

The axis of the 3D rotation for the selected objects can be specified in Edit > Transform > Rotate in 3D. This can also be done through the context menu.

The following options are available:

  • Around Arbitrary Axis: Defined by two atoms. In this case, you are asked to select the bond before the rotation.

  • Around X Axis: Horizontal axis in the plane of the canvas.

  • Around Y Axis: Vertical axis in the plane of the canvas.

  • Around Z Axis: Axis perpendicular to the plane of the canvas.

  • Free 3D Rotation: The rotation follows the movement of the mouse (click and drag).

  • Group Rotate: Available only for a selected group in a molecule. The connecting bonds are recognized between the selected and unselected parts of the structure and the rotation axis is selected accordingly.

The rotations can be visualized with the fog effect, that is, parts of the molecule behind the canvas are of a lighter color than the parts on the canvas. For more information, see the 3D Options Tab.

For the best 3D view, it is recommended to set the background white. The color of the background can be changed through View > Colors > White Background.

Currently, 3D coordinates of brackets (e.g. monomer, component type groups) are not correctly updated when rotating the molecule in 3D mode.