Import File-File Tab

After clicking the Import button on the ribbon and starting the import process, the Import File dialog opens.

images/download/attachments/1803107/Import_File_Dialog_File_Tab.png

The File tab consists of the following parts:

  • File to Import

  • Format Specific Import Options

  • To Workbook and Worksheet

  • Data Placement

File to Import

By clicking the folder icon next to the field, you can choose the file to be imported. Alternatively, you can enter the file path to the field manually.

A red exclamation mark with a tooltip is displayed if the specified file does not exist or file format is not supported.

Format Specific Import Options

  • Skip Atom Values: It is possible to import structures from the SD files without atom numbers by selecting this check-box. The check-box is unselected by default.

To Workbook and Worksheet

The destination workbook and worksheet can be specified for the import. Use the combo box to specify the desired workbook and worksheet.

The active worksheet is selected by default, and the imported data will be mapped at the end of the sheet (last used cell in the file).

It is also possible to create a new worksheet for the import by typing in a name for the new sheet. A red exclamation mark with a tooltip indicates if the entered sheet name already exists, contains a not allowed character, or the field is left blank.

In Office 2013 and newer Office versions, it is not possible to import to another workbook, the drop-down list is deactivated, only the worksheet can be selected.

Use the Rename Target Worksheet checkbox to overwrite the name of the selected worksheet with the name of the imported table.

The target worksheet cannot be renamed if the name of the selected table contains any characters that are not allowed in sheet names, for example, square brackets.

The default state of the checkbox can be specified in Options > General > Worksheet Name.

Data Placement

  • Append: By using this radio button when importing structures with their properties to a worksheet, which is not empty, the new structures and data are appended to the existing ones.

  • Overwrite: By using this radio button when importing structures with their properties to a worksheet, which is not empty, the existing structures and data are overwritten by the imported ones.

    • Start: When overwriting the existing data, it is possible to specify a starting cell for the process. The column and row number can be specified or the active cell can be selected as a starting cell.

  • Create Header: It is possible to import the structures and their data with or without headers by selecting or unselecting this checkbox. The checkbox is selected by default.

  • Transpose: It is possible to import the structures and their data into columns instead of rows by selecting this checkbox. The checkbox is unselected by default.

Click the Next button to switch to the next tab.