Export to File

You can export structures and additional fields from Excel worksheets to a wide variety of file formats.

Use this function to export structures to file formats that support multiple structures.

The following file formats are supported:

  • ChemAxon MRV format

  • Daylight Smiles

  • ChemAxon extended Smiles

  • MDL SD File

  • MDL SD File V3000

  • MDL RD File

  • MDL RD File V3000

  • MDL RXN File

  • MDL RXN File V3000

  • IUPAC Names

The MDL SD File format is used by default. It can be changed in Options > File Export > File Format > Default Export File Format.

Only one column containing structures can be exported. Column headers must be specified for columns to export.

The Export File dialog contains the following tabs:

  • File

  • Columns

  • Progress

images/download/attachments/1806096/Export_File_Button.png

File Tab

The File tab contains the following options:

  • Export to file: By clicking the Save icon the Save File dialog opens. You can then specify the destination folder, the file format, and the file name. The file name with its path is displayed on the Export File form. A red exclamation mark with a tooltip indicates errors.

  • Format Specific Export Options

    • Crete No Structure: If this box is checked, you can export data without having a structure column. In this case, no structures will be exported to the generated SD file. The checkbox is unselected by default.

    • Molecule Title Column: By using this drop-down list, you can set a custom string, for example, IUPAC name or any other string as MOL header line in case of SD files.
      The strings from the selected column are displayed in the first line of the MOL section in the exported SD file.
      This field can be exported to any other file formats, which contain a header line possibility.
      The default option is <IDs if exist>. This means if the worksheet contains a JCIDSYSStructure function, the ID included in it will be exported in a molecule title row, for example, in the case of SD Files.
      For more information, see JCIDSYSStructure.

  • Source

    • Workbook: Displays the name of the workbook from which the export was started.

    • Worksheet: Use the drop-down list to select the worksheet you want to export. The active worksheet is selected by default.

    • Range: After selecting the worksheet, the applied range is displayed in this box.

    • Selection Only: Check this box to export only a selected range. The checkbox is unselected by default.

    • Export Hidden Rows: Check this box to export the content of the hidden rows. The checkbox is unselected by default.

  • Structures Only: Check this box to export only the structures from the specified worksheet. The export process does not require any header if only structures are exported. The checkbox is unselected by default.

  • Structures Only Export Options

    • Left-Right-Top-Bottom: Use this radio button to specify the order as left-right-top-bottom when exporting from a worksheet with multiple structure columns. The radio button is only available if the Structures Only checkbox is selected.

    • Top-Bottom-Left-Right: Use this radio button to specify the order as top-bottom-left-right when exporting from a worksheet with multiple structure columns. The radio button is only available if the Structures Only checkbox is selected.

Columns Tab

If the specified file format of the export can handle additional properties, you can specify the columns for export on this tab. It is possible to select only one structure column in case of worksheets with multiple structure columns.

By unselecting the Use Row Values As Property Names checkbox, column letters can be exported as column headers. This checkbox is selected by default and the specified column headers are exported in this case. You can specify the row values to be exported as column headers by specifying the row number in the field at the top of the Columns tab.

The Columns tab is disabled if the Structures Only option is selected on the File tab and all structures can be exported into the specified file from a worksheet with multiple structure columns in this case.

A structure column is mandatory if the Create No Structure option is not selected on the File tab.

images/download/attachments/1806096/Export_File_Columns_Tab.png

Clicking the Next or the Export button starts the export process.

Progress Tab

The progress bar displays the status of the export process. If any error occurs during the process, error messages will be displayed on this tab.

images/download/attachments/1806096/Export_File_Progress_Tab.png

The export process can be canceled by clicking the Stop button. After the export process is finished the dialog closes automatically.

The exported file can be found in the specified folder and it contains all exported information.