Editing the Source

You can alter a molecule by editing its source directly in the Edit Source dialog window. This window is available through the Edit > Source.

The dialog window provides standard clipboard operations. You can view and edit the source in any of the supported file formats.

It is also possible to convert it to a Java String which allows the easy integration of the structure to a custom Java application code.

Editing the Source

You can change the format of the source by simply selecting the desired format from the View menu.

If there is more than one molecule on the canvas, setting View as multiple molecules in the View menu causes each molecule to appear in a separate block in the source.

This feature works only in those cases where the selected format can handle multiple fragments.

images/download/attachments/1805745/Edit_Source_Format.png

When finished editing the source you can import the structure back to the MarvinSketch canvas by using File > Import As.

When importing, you can choose from the following two import modes:

  • Import As Recognized: Imports in the current file format.

  • Import As: You can specify the file format.

images/download/attachments/1805745/Edit_Source_Import_As.png